Error Activating Site Collection Feature

Feb 3, 2009 at 7:59 PM
Hello,
I have a 64bit sharepoint farm, with 2 WFEs, 1 index, and SQL Cluster. I added the .wsp from WFE1 and then deployed it using stsadm. --> Seems good so far.

But now, I go to Site Collection Features, to activate, and I get an error:
"Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))"


So, confused, I go to solution management, in Central Admin, and the solution says "DeployING", not DeployED. And, it's hung, and I can't even retract.

I have tried this same process on standalone sharepoint server and it works great.

I have tried this on 2 different multi WFE sharepoint servers, and the feature fails to activate?

Any advice?

Thanks,
KPT
Feb 4, 2009 at 3:46 PM
Update, the solution now says DEPLOYED. so that part is now good, but I still am not able to Activate the Site Collection Feature. I get the same error as above: "Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION))"

Is this related to the timer job? or what would be best place to check what is going wrong when trying to activate the feature. (It did create the SPList called Vanity Redirect, but the custom Content Type does not show as part of this SPList).

Thanks again,
KPT